(DONE) Booten von Instant-Grid bei vorhandenem DHCP

Submitted by Andreas Hoheisel on Thu, 02/11/2006 - 09:29.

Hallo,

Wenn im lokalen Netzt bereits ein DHCP vorhanden ist, holt sich der (server)-Rechner seinen hostname anscheinend vom DHCP und vergisst, dass er eigentlich "server" heißen sollte. Wenn man dann obendrein mit dem Internet verbunden ist, erscheint dann auf der Start-Seite von Firefox nicht wie gewohnt die Instant-Grid-Seite, sondern irgendeine Seite im Internet, auf die man (vom Provider?) weitergeleitet wurde. Bei mir zu Hause ist es http://de.wikipedia.org/wiki/Server, im Büro komme ich auf http://httpd.apache.org/.

Alles im allen finde ich das etwas verwirrend, und ich denke wir sollten den Bootprozess bei vorhandenem DHCP entweder abändern, oder zumindest besser dokumentieren. Die Datei /etc/hosts enthält in diesem Fall nur den Eintrag "localhost".

Wir können das ja nächste Woche in Göttingen nochmal ausführlich testen und diskutieren,

Gruß, Andreas

(hoffentlich) fixed in Revision 533

Hallo,

wir sind dem Problem inzwischen (hoffentlich) auf den Grund gegangen. Die Problem scheint bei Rechnern mit Firewire aufzutreten, da das Firewire Interface als ethX erscheint, wird es auch u.U. als IG Interface verwendet.

Wenn das der Fall ist, schlagen aber jegliche Broadcast und Ping Versuche fehl und der ipcollectord kommt voellig ins Schleudern.

Mit der Aenderung ab dem nightlybuild vom 25.11.06 sind nur noch solche Interfaces moegliche Kandidaten, die sich mit ifconfig als "Link encap:Ethernet" ausgeben.

Also hoffentlich nun wirklich "done".

Hallo Andreas, ich kann das

Hallo Andreas,

ich kann das leider bei unserem DHCP Server nicht reproduzieren. Ich habe eben das Release 0.5 und Nightly-Build vom 02. 11. probiert. Habe nur ein Interface konfiguriert. Auf dem Interface antwortet der DHCP-Server vom Mitarbeiternetz.

Ich werde dann beim Booten aufgefordert das dummy0 zu nehmen. Danach startet alles und in /etc/hosts ist sowohl der Eintrag "localhost", als auch der Eintrag "server".

/etc/resolv.conf ist dann ersetzt worden. Der Hostname ist weiterhin "server". Laut pump-Doku (der DHCP-Client von Knoppix) setzt pump niemals den Hostnamen neu, auch wenn der DHCP-Server den Client dazu bringen möchte.

Kannst Du evtl. noch mehr Input geben?

Danke

Tim

DHCP zu Hause

Ich habe es in unserem privaten Hausnetz getestet. Der PC hat zwei Netzwerkarten und hängt in einem LAN in dem ein Debian-Rechner mit dhcpd3 läuft. Dazwischen hängen zwei Switches. Die andere Netzwerkarte im PC wird nicht verwendet. Ich muss das aber nochmal zu Hause testen und kann dann mehr Infos hierzu geben. Gibt es irgendeine zentrale IG-spezifische Log-Datei, die den Boot-Vorgang dokumentiert? Ich probiers mal mit dmesg...
Ich versuch es gleich auch mal im Institutsnetz (und hoffe es gibt keinen Ärger:-)

Test im Institutsnetz OK

Ich habe es gerade im Insitutsnetz probiert, da scheint alles zu funktionieren (hostame = server). Dann nehm ich Instant-Grid mal übers Wochenende mit nach Haus und berichte nächste Woche.

Da sich der Fehler nicht

Da sich der Fehler nicht reproduzieren lässt, habe ich ihn vorerst auf "Done" gesetzt. Gegebenenfalls bitte einen neuen Thread öffnen.

Bin wieder da

Ich hatte es nicht mehr geschafft, das vor meinem Urlaub nochmal zu Hause zu testen. Jetzt bin ich wieder gut erholt zurück und werde es vor Weihnachten mit der aktuellen testing-Version probieren und gegebenfalls das DONE wieder entfernen:-)

Apropos Weihnachten: Gibt es dieses Jahr wieder eine Weihnachtsedition von Instant-Grid? Wir könnten ja den klassiker "xsnow" mit installieren und automatisch ausführen...